티스토리 뷰

python

pip로 python3 의존성 설치하기

LichKing 2018. 2. 18. 16:58
SMALL

파이썬 의존성들을 설치할때 pip 패키지 관리자를 사용하게된다. 이때 python2.x, python3.x 버전이 모두 있을경우 pip로 설치시 python2 버전에 해당하는 의존성들을 받게된다. 애초에 왜 python 버전을 2개 다 갖고있나생각할 수도있지만 Mac의 경우 기본적으로 python2.x 를 내장하고있기때문에 나중에 3를 설치한다면 이런 문제에 맞딱뜨릴수밖에 없다.(python2 지워버릴까 고민중..)


이럴땐 pip3 명령어로 python3 용 의존성을 받을 수 있다.


예) pip3 install scrapy

LIST
댓글
댓글쓰기 폼